OpenWrt编译报错 Please do not compile as root

【问题】

Build dependency: Please do not compile as root.
Prerequisite check failed. Use FORCE=1 to override.

 

【解决】

修改   include/prereq-build.mk 文件中,如下内容注释掉即可(在前面加上#注释符号)

#define Require/non-root
# [ “$$(shell whoami)” != “root” ]
#endef